Hello Paulitacq!

In order to downgrade to 5.0.5, you need to still have Mac OS 10.6.8 installed. The update will not work with Lion (10.7). It would be good to double-check that first.

If you still have 10.6.8 installed, follow this link: http://support.apple.com/kb/DL1399 Once you're on that page, download and install the Combo Update to revert Safari back to 5.0.5.

An alternate solution if you have Lion (or if you do not want to deal with Safari automatically updating to the version that does not work with DE) is to use an alternate internet browser called Firefox. You can download that from this link: http://www.mozilla.com/en-US/firefox/new/

After you've installed Firefox, you must tell the Tapestry DE to always open with Firefox. To do that, right-click on your Tapestry DE icon on your desktop, mouse over Open With, and select Other... (not Firefox). Then select Firefox from the applications list and be sure to check the Always Open With check box below.

Either way you choose, you should be able to view your files again. Please let me know if you have any questions!